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1. AdaptiveMT

2. Fragment Recall (upLIFT)

3. Fuzzy Match Repair (upLIFT)

4. Upgrading TMs required

Studio 2017 New Features
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Studio 2017 New Features: AdaptiveMT 
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Available free with active SDL Trados Studio 2017 license

Free package:

▪ 400,000 characters/month

▪ 1 AdaptiveMT engine

▪ Can be used alongside Translation 
Memories or other Machine 
Translations

▪ Access to all baseline MT engines 
from SDL Language Cloud

General overview (video):
http://www.sdl.com/video/studio-2017-
introducing-sdl-adaptivemt/111026/

Pricing options:
http://www.sdl.com/solution/language/translation-productivity/machine-
translation/pricing.html

SDL AdaptiveMT: Getting Started
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1. Project Settings > Use > SDL Language Cloud Machine Translation

2. Enter your SDL Account details that you use when purchasing SDL software

3. SDL Language Cloud auto detects project language pair

4. Click on Manage Adaptive Engines to create your AdaptiveMT engine

5. Click on New Adaptive Engine  > give it a name & set language pair*

6. Select your new AdaptiveMT engine from dropdown list. [= lightbulb icon]

7. It is now added to your project. Make sure the Update is ticked so your post-edits are fed 
back to your engine

*As of now only available from EN into FR, IT, DE, ES and Dutch….[meh]..so if you are like me, we wait!
Source: http://www.sdl.com/video/studio-2017-getting-started-with-sdl-adaptivemt/111027/

http://www.sdl.com/video/studio-2017-introducing-sdl-adaptivemt/111026/
http://www.sdl.com/solution/language/translation-productivity/machine-translation/pricing.html
http://www.sdl.com/video/studio-2017-getting-started-with-sdl-adaptivemt/111027/
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System Settings: Global vs. Project
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▪ Global settings are universal 
(from Home or within Editor, “File” > “Options”)

▪Project settings are project-specific
(from Projects or within Editor, “Project Settings” 

test

t
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How to enable Fragment Recall: 

1. File>Options>Editor>Fragment Matches 
Window and activate the “Display results…” 
box:

2. Change colors if you don’t like the default khaki 
highlighting

3. File>Options>AutoSuggest and activate 
“Fragment Matches”:

4. File>Options> Language Pairs>All Language 
Pairs>TM and Automated Translation>Search 
and enable TU fragment

Studio 2017 New Features: Fragment Recall (upLIFT)

Source: https://signsandsymptomsoftranslation.com/2016/11/17/studio-2017-uplift/

Result: 

https://signsandsymptomsoftranslation.com/2016/11/17/studio-2017-uplift/


3/23/2017

4

© j.clark 

How to enable Fuzzy Match Repair: 

1. File>Options>Language Pairs>All Language 
Pairs>Match Repair and activate “On”. 

• If you want to use machine translation for match 
repair, enable it here too (red circle):

2. TMs must be upgraded to use upLIFT 
(fragment recall and repair technology) 
Two steps:

• Translation model is built

• Segment fragments identified and aligned

Studio 2017 New Features: Fuzzy Match Repair 
(upLIFT)

Source: https://signsandsymptomsoftranslation.com/2016/11/17/studio-2017-uplift/

Result: 

Segments are repaired using a variety of resources: termbases, aligned translation models (reindexed TMs), 
current TMs, fragment recalls and MT

When a match is repaired, the match % remains unchanged 
and a new symbol is visible, i.e., the % match indicated is still 
the original fuzzy value. 

3. Fragment Alignment > Click the status to “On”

• Studio can build the translation model and align the 
TUs  for you, do you want to proceed? > “Yes”

4. Click “Align new content automatically”

© j.clark 

Two ways to upgrade TMs for upLIFT: manually and via Reindex TMs app 

Studio 2017 New Features: Upgrading TMs (Manual)

Source: https://signsandsymptomsoftranslation.com/2016/11/17/studio-2017-uplift/

1. Translation Memories View > Open a TM
(it must have >1K segments; if it does not, then try 
Reindex TMs app [SDL recommends 5K seg.])

2. Right-click it in view window > “Settings”

https://signsandsymptomsoftranslation.com/2016/11/17/studio-2017-uplift/
https://signsandsymptomsoftranslation.com/2016/11/17/studio-2017-uplift/
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To utilize 2017’s new upLIFT (fragment matching) | Drag and drop multiple TMs  | Studio17+

NOTE: This process will take a while (may want to run overnight). Also, make sure no TMs are open in your 
Translation Memory view so they aren’t “locked” for editing (causing error).

Instructions:

1. Download/Install app.

2. Restart Studio.

3. App appears on home screen.

4. Drag and drop TMs into the top screen.

5. Tick “Re-Index” and “Uplift” > Process.

6. [Finished:] “Process time XX:XX:XX”.

7. App saves TMs in original location.

▪ Old labeled as “…_original”.

▪ New TMs will be larger.

Download: http://appstore.sdl.com/app/reindex-tms/419/

More info: https://multifarious.filkin.com/2016/11/17/more

-power-to-the-elbow-uplift/

Studio 2017 New Features: Upgrading TMs
(Reindex TMs app)

SDL OpenExchange App Store

© j.clark 

http://www.translationzone.com/openexchange/

▪ Apps and plug ins extend functionality.

▪ Most of the 120 apps are FREE!

▪ SDL My Account login needed to download.

▪ Use the “App search” to find the apps we 
cover today.

▪ And/or browse the other categories.
More info: SDL Webinar: Be more productive with popular apps from the SDL OpenExchange 
App Store

http://appstore.sdl.com/app/reindex-tms/419/
https://multifarious.filkin.com/2016/11/17/more-power-to-the-elbow-uplift/
http://www.translationzone.com/openexchange/
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Popular Apps: Studio Migration Utility
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EASY way to migrate from one version of SDL Trados Studio to another! 
(clean up old version and migrate BEFORE you uninstall from computer)

Instructions:

▪ Download/Install app.
▪ Restart Studio.
▪ Open app.

(Ribbon of Studio > Add ins > Studio Migration Utility)

▪ Indicate from which version.
▪ Indicate to which version.
Note: It looks in Trados’ default location and will copy 
over from 2015 default location to 2017. (It does not 
delete them and it is not actually “moving” TMs.)

Download: http://appstore.sdl.com/app/studio-migration-utility/481/

More info: 
• http://blog.translationzone.com/ready-switch-sdl-trados-studio-2017-studio-

migration-utility-tool/
• https://multifarious.filkin.com/2015/07/06/walhfmf/ (P. Filkin)

•Projects
•Customer lists
•Translation memories
•Language resource templates
•SDL AppStore plugins (only between 
Studio 2015 and Studio 2017)

Popular Apps: MyMemory (MT plug in)
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Important Setting Tips:

World’s largest TM | Contains TMs from the EU, UN, websites | User-added content (!)

▪ Uncheck “Update” box 

• Or you will be adding your 
translations to MyMemory!

▪ Add to Global Settings under “All 
Language Pairs”

http://appstore.sdl.com/app/reindex-tms/419/
http://blog.translationzone.com/ready-switch-sdl-trados-studio-2017-studio-migration-utility-tool/
https://multifarious.filkin.com/2015/07/06/walhfmf/
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Popular Apps: MyMemory (MT plug in)
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World’s largest TM | Contains TMs from the EU, UN, websites | User-added content (!)

Global Setting Tip:

▪ Deactivate “Apply best match after 
successful lookup”.

(File>Options>Editor>Automation)

MT result shows up in Translation 
Results window, but isn’t auto-inserted. 

This way, you can use AutoSuggest or 
“Apply Translation” shortcut.

Popular Apps: “SDL Analyse”

© j.clark 

Quickly analyze files (drag and drop, or zip files) | Standalone or inside  | Studio17+

Instructions:

▪ Download/Install app.

▪ Restart Studio.

▪ Open app.
Apps (on computer) > SDL Analyse –
or open from inside Studio 2017

▪ Drag and drop files or click “Add files”.

▪ Click “Add TM” if you want to analyze using TM.

Installation tips/troubleshooting: https://community.sdl.com/solutions/language/translationproductivity/w/customer-experience/1311.sdl-analyse

https://community.sdl.com/solutions/language/translationproductivity/w/customer-experience/1311.sdl-analyse
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Popular Apps: Glossary Converter (stand alone)

© j.clark 

Instructions:

▪ Download/Install app.

▪ Restart Studio.

▪ Open app.
(Apps (on computer)  > SDL OpenExchange > Glossary Converter)

▪ Navigate to Excel glossary.

▪ Click it and hold (left mouse button). 

▪ Drag and drop into the

glossary converter space.

More info: Paul Filkin’s video “Glossary Converter in Practice” at https://www.youtube.com/watch?v=2HFAMiPbQJs

Result:

▪ MultiTerm sdltb now in folder!
(The .mdf and .mtf files that you see are just reference files that 
the app creates in the background for MultiTerm’s benefit.)

Glossaries <> MultiTerm termbases | Simple Drag and Drop Interface | xls(x), csv, txt, tbx, utx, tmx

Popular Apps: AnyTM

© j.clark 

Use any TM regardless of SL and TL | Reverse TM direction | Mixed SL document translation

▪ Download/Install app.

▪ Restart Studio.

▪ Likely go to “project settings” (not global settings)

(depending where you want to add/use TM).

▪ > Translation Memory and Automated Translation

▪ > Language Pairs

Click “Add”, select from the following options:

• “AnyTM: Any file-based TM” [most often]

• “AnyTM: Any server-based TM”

• “AnyTM: Any other translation provider” 

Instructions: Result:

▪ Reference DE>GB TM in DE>US project!

▪ Reference EN>DE in DE>EN project!

https://www.youtube.com/watch?v=2HFAMiPbQJs
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Results:
TEST

Popular Apps: PackageReader

© j.clark 

Preview pkgs (xliffs, stats) w/o opening Studio | From email/Windows Explorer | 1-click to open

▪ Download/Install app.

▪ Restart Studio.

▪ Receive client email including Studio Package.

Instructions:

▪ Double click on the Studio package inside email.

▪ Confirm that you want to “Open” attachment.

TEST.sdlppx (8 MB)

TEST

▪ Clicking “Files” even lets you see the xliffs.

▪ Click “Open pkg in Studio” to get to work.

Popular Apps: SDL Trados Studio Bookmarks

© j.clark 

Add custom bookmarks | Auto tracks last segment | xliff opens to last accessed segment

▪ Download/Install app.

▪ Restart Studio.

▪ Open a document inside Editor.

Instructions:

▪ xliff  opens to last accessed segment automatically.

Results:

▪ Custom bookmarks can be added with notes.

▪ Click “Advanced” tab at top of document.

• Bookmark functions now visible in ribbon:

▪ Bookmarks can be easily seen and accessed.
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Popular Apps: SDL Trados Studio Symbols
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Easily insert special characters & symbols | Easy short cut buttons

▪ Download/Install app.

▪ Restart Studio.

▪ Open a document inside Editor.

Instructions:

▪ Shortcuts

▪ Insert “®” just by clicking on symbol above  

▪ Hover mouse over “®” to see new assigned 
shortcut is (Alt+Shift+1).

▪ Click “Advanced” tab at top of document.

• “Insert Symbol” button now visible in ribbon:

Results:

▪ Used symbols are added and assigned shortcuts

Popular Apps: Dictionary Plugin
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Double-click any word (SL or TL) to see definition

▪ Download/Install app.

▪ Restart Studio.

▪ Open a document inside Editor.

Instructions:

▪ Click “Advanced” tab at top of document.

• “Dictionary Lookup” button now visible in 
ribbon:

▪ Double-clicking any Source or Target word pulls up 
definition. (I use the default dictionary “Glosbe”)

Results:
▪ “Lookup Enabled” now activated
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Helpful Resources
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▪ Translators Talk Trados http://www.translationzone.com/landing/translator/translators-talk-
trados.html?utm_medium=email&utm_source=translationzone.com&utm_campaign=Translators+Talk+Trados&u
tm_content=EmmaG+landing+page

▪ Paul Filkin’s multifarious blog https://multifarious.filkin.com/2015/07/06/walhfmf/

▪ Emma Goldsmith’s blog: https://signsandsymptomsoftranslation.com/2016/11/24/studio-2017-new-features/
(SP > EN medical translator)

▪ PLUS…..numerous SDL resources on welcome screen of Studio (Get Started, More Resources, Latest News)

http://www.translationzone.com/landing/translator/translators-talk-trados.html?utm_medium=email&utm_source=translationzone.com&utm_campaign=Translators+Talk+Trados&utm_content=EmmaG+landing+page
https://multifarious.filkin.com/2015/07/06/walhfmf/
https://signsandsymptomsoftranslation.com/2016/11/24/studio-2017-new-features/

